Neuigkeiten:

moziloCMS verwendet Cookies. Wenn Sie auf unserer Seite weitersurfen, stimmen Sie der Cookie-Nutzung zu Datenschutzerklärung
moziloCMS Layouts
moziloCMS Plugins

Hauptmenü

Neueste Beiträge

#1
Plugins / Antw:Calendar-Plugin und SSL
Letzter Beitrag von rolinux - 30. November 2022, 18:35:09
mozilo Rev.55, Calendar war Rev.2. Was ich halt auf der mozilo-Homepage gefunden habe.
Aber jetzt habe ich grade das Calendar-Plugin aus dem Thread installiert und es funktioniert.
Vielen Dank. Wie immer hier schnelle und einfache Hilfe.

Gruß
Rolf
#2
Plugins / Antw:Calendar-Plugin und SSL
Letzter Beitrag von marusti - 30. November 2022, 13:30:48
Welche Rev nutzt du? Ich habe den Artikel gefunden https://www.mozilo.de/forum/index.php/topic,4108.msg20999.html#msg20999 und die Version von dem Link herunter geladen und es funktioniert bei mir.
#3
Plugins / Calendar-Plugin und SSL
Letzter Beitrag von rolinux - 29. November 2022, 19:25:07
Hallo,

ich will die Homepage meines Vereins auf moziloCMS umstellen und brauche dazu u.a. das Calendar-Plugin. Ich habe die mozilo-Installation mit einer Subdomain verknüpft, die mit php 8.0 und SSL laufen soll. php 8.0 kann ich nicht ändern, weil mein Hoster alle älteren php-Versionen abgeschaltet hat. Aber php 8.0 ist auch nicht das Problem. Damit funktioniert moziloCMS gut. Das weiß ich von einer anderen meiner mozilo-Homepages.

Was Probleme macht, ist anscheinend die SSL-Verschlüsselung beim Calendar-Plugin. Ich bekomme im Backend beim Klick auf "Verwalten" eine Reihe Fehlermeldungen:
ZitatWarning: Attempt to read property "lang" on bool in /.../gammoz/plugins/Calendar/admin/index.php on line 260

Warning: Trying to access array offset on value of type null in /.../gammoz/plugins/Calendar/admin/index.php on line 260

Warning: Trying to access array offset on value of type null in /.../gammoz/plugins/Calendar/admin/index.php on line 260

Warning: Attempt to read property "lang" on bool in /.../gammoz/plugins/Calendar/admin/index.php on line 261

Warning: Trying to access array offset on value of type null in /.../gammoz/plugins/Calendar/admin/index.php on line 261

Warning: Trying to access array offset on value of type null in /.../gammoz/plugins/Calendar/admin/index.php on line 261

Warning: Attempt to read property "lang" on bool in /.../gammoz/plugins/Calendar/admin/index.php on line 262

Warning: Trying to access array offset on value of type null in /.../gammoz/plugins/Calendar/admin/index.php on line 262

Warning: Trying to access array offset on value of type null in /.../gammoz/plugins/Calendar/admin/index.php on line 262

Warning: Attempt to read property "lang" on bool in /.../html/gammoz/plugins/Calendar/admin/index.php on line 263

Warning: Trying to access array offset on value of type null in /.../gammoz/plugins/Calendar/admin/index.php on line 263

Fatal error: Uncaught TypeError: implode(): Argument #1 ($pieces) must be of type array, string given in /.../gammoz/plugins/Calendar/admin/index.php:263 Stack trace: #0 /.../gammoz/plugins/Calendar/admin/index.php(263): implode() #1 /.../gammoz/plugins/Calendar/admin/index.php(106): CalAdmin->insertHead() #2 /.../gammoz/plugins/Calendar/admin/index.php(354): CalAdmin->getAdminContent() #3 /.../gammoz/melddichan/plugins.php(65): require_once('...') #4 /.../gammoz/melddichan/index.php(290): plugins() #5 {main} thrown in /.../gammoz/plugins/Calendar/admin/index.php on line 263

Ich habe keine neuere Version gefunden als die in den Erweiterungen auf der mozilo-Homepage.

Kann mir jemand helfen?

Gruß
Rolf
#4
Neue Versionen / Antw:PHP 8
Letzter Beitrag von Oggel - 26. November 2022, 15:11:24
Hallo marusti,

vielen Dank für die schnelle Antwort.

Dann werde ich mal rumprobieren, in der Hoffnung, dass das klappt   ::)   !
#5
Neue Versionen / Antw:PHP 8
Letzter Beitrag von marusti - 26. November 2022, 11:18:55
Hallo Oggel,

die aktuelle Version läuft unter PHP8,  hier ist der Link mit Update Anleitung https://www.mozilo.de/forum/index.php/topic,4574.0.html

Falls du noch mozilo 1.12 nutzt, siehe hier https://www.mozilo.de/forum/index.php/topic,4555.0.html
#6
Neue Versionen / PHP 8
Letzter Beitrag von Oggel - 25. November 2022, 22:21:30
Hallo,
mein Provider (Host Europe) hat auf PHP 8 umgeschaltet und jetzt funktionieren meine Seiten nicht mehr.
Gibt es eine Mozilo-Version mit PHP 8 und was muss ich dann tun, damit die Seiten wieder angezeiget werden?
Vielen Dank im Voraus,

Gruß, Oggel
#7
Plugins / Antw:Plugin MenuSubs funktioni...
Letzter Beitrag von rolinux - 24. November 2022, 17:12:50
Heureka!
Der Hinweis auf die css-Datei des Plugins und vor allem dass das Plugin mittlerweile zum mozilo-Standard gehört haben mich auf die richtige Spur gebracht.
Beim Update auf Rev.55 wurde dadurch natürlich auch das Plugin MenuSubs überschrieben und also auch die css-Datei des Plugins. Aber man macht ja vorher eine Datensicherung und da war die css-Datei ja noch. Also hochgeladen und alles ist wieder gut! Also doch kein Wochenende mit CSS-Klassen! 8)

Vielen Dank für Eure Bemühungen und Hinweise! War erfolgreich!

Jetzt könnt Ihr Euch zur Belohnung noch anschauen, wie die HP richtig aussehen soll. Aber immer noch mit ohne SSL. Das ist das nächste, was ich angehe. Und das responsive Layout, dass ja mit Rev.55 jetzt auch möglich sein soll mit dem Standard-Layout. Aber das sind dann neue Thread, wenn nötig.

Gruß
Rolf
#8
Plugins / Antw:Plugin MenuSubs funktioni...
Letzter Beitrag von marusti - 24. November 2022, 16:58:43
Kann es sein das du selbst Änderungen in der plugin.css vorgenommen hattest? Wenn ja ist die Datei beim Update überschrieben worden. Wenn du noch ein Backup von Rev51 hast, könntest du da nachschauen und die Datei mit deiner alten Version ersetzen.

Laut Github wurde vor 8 Jahren das letzte mal der Code von diesem Plugin geändert.
#9
Plugins / Antw:Plugin MenuSubs funktioni...
Letzter Beitrag von rolinux - 24. November 2022, 15:54:14
Naja, schön ist es ja nicht. Vorher waren die Menüeinträge farbig hinterlegt, nicht als Aufzählung gelistet und auch in schönen Kästchen.
Und wenn Du mal in "Unsere Gruppen -> Südbaden" gehst, siehst Du das Submenü, das eigentlich über der Inhaltsseite in bis zu zwei Zeilen stehen soll und nicht untereinander gelistet. Deshalb das Plugin MenuSubs.

Aber dann muss ich mich vermutlich mal mit dem CSS beschäftigen. Kann es sein, dass mozilo irgendwann zwischen Rev.51 und Rev.55 die CSS-Klassen in den Menüs geändert hat? Das wäre vlt. eine Erklärung, warum das nicht angezeigt wird. Im Idealfall gibts dafür doch sicher irgendwo eine Doku "alte CSS-Klasse -> neue CSS-Klasse"...? ;) Nein? Dann muss ich halt Hirnschmalz reinstecken... :o

Gruß
Rolf
#10
Plugins / Antw:Plugin MenuSubs funktioni...
Letzter Beitrag von marusti - 24. November 2022, 14:57:22
stimmt,mit http geht es.
In der plugin.css von MenuSubs gibt es keine wirklichen Anweisungen für die Menülinks. Das war aber in Rev51 auch schon so (hab noch eine Version gefunden), d.h. daran hat sich nichts geändert.
Das Menü wird bei mir mit Aufzählungszeichen und mit dem gleichen Style wie für andere Links dargestellt.
Was genau möchtest du daran geändert haben?