Neueste Beiträge

Seiten: [1] 2 3 ... 10
1
Betatests / Antw:moziloCMS 2.0 Rev53 RC1
« Letzter Beitrag von marusti am 14. Juni 2021, 16:27:54 »
Hallo Klemens,
es ist 3. die direkt mitgeliefert werden.
Alles bei 2. sind Plugins die andere Nutzer bereit gestellt haben. Auf der Seite selbst steht bei einigen gleich mit wer das Plugin erstellt hat, anderenfalls kannst du in den Plugineinstellungen sehen von wem das Plugin stammt (siehe https://mozilo.de/moziloCMS%202.0/Anleitung/Plugins.html ganz unten bei "Autor")
2
Betatests / Antw:moziloCMS 2.0 Rev53 RC1
« Letzter Beitrag von Klemens am 14. Juni 2021, 01:03:24 »
hi Marusti,
ich danke dir für deine Erklärung. Das hatte ich so nicht verstanden.
Wobei ich jetzt auf eine ergänzende Erklärung / Hilfe angewiesen bin:
Ich kenne neben einigen Einzel-Websites mit Bezug zu Mozilo im Wesentlichen zwei Quellen für PlugIns
1. https://github.com/mozilo-plugins
2. https://www.mozilo.de/media/Plugins%202.0.html
als auch
3. die mit mozilo2.0-master.zip ausgelieferten Plugins

zu 1.) dass dies eine Sammlung verschiedenster Quellen sein wird, ist zu vermuten, liegt m.E. auf der Hand
aber:
zu 2.) die dort gelisteten (als gesamt-Zip angebotenen) Plugins hätte ich auf Grund
der Plazierung als gleichwertig gelisteter Punkt auf der Website als Systemstandard verstanden.
zu 3.) oder werden als "Standard" ausschließlich die mit der mozilo2.0-master.zip ausgelieferten Plugins verstanden?
Dazu gehört die TermContent dann allerdings nicht.

Ich fand jedenfalls auf der Webseite keinen Hinweis auf diesen Umstand,  keine für den Nutzer erkennbare Unterscheidung was Standard, was nicht.


@Laborix, @ marusti
Bestätigung und erfreulich(!): Das Plugin "TermContent Version 2018-10-24" läuft in der oben bereitgestellten Download-Version
sowohl mit der Sprachumgebung PHP7.4.20 als auch unter PHP8.07 (andere Versionen nicht getestet)
3
Betatests / Antw:moziloCMS 2.0 Rev53 RC1
« Letzter Beitrag von marusti am 13. Juni 2021, 21:02:10 »
Hallo Klemens,
was damit gemeint ist...die Standard Plugins von mozilo laufen natürlich unter PHP8 (wie du auch bestätigt hast).
Sämtliche andere Plugins die du unter https://www.mozilo.de/media/Plugins%202.0.html finden kannst, sind keine Standard Plugins, sondern von mozilo Nutzern selbst bereit gestellte Plugins. Diese werden nicht von mozilo gepflegt (können wir auch gar nicht vom Aufwand her). Dort müsste man sich an den jeweiligen Programmierer bei Problemen wenden oder alternativ nach Hilfe im Forum von anderen Nutzern fragen. Das Problem ist, dass die meisten dieser Plugins vor vielen Jahren programmiert wurden (noch unter PHP 5.x) und die meisten Programmierer nichts mehr aktiv mit mozilo machen. Daher gab es auch schon die Probleme bei der Umstellung auf PHP 7.x siehe hier https://www.mozilo.de/forum/index.php/board,34.0.html wenn du etwas weiter runter scrollst. Bisher hat sich aber immer noch jemand gefunden, der weiterhelfen konnte. 
4
Betatests / Antw:moziloCMS 2.0 Rev53 RC1
« Letzter Beitrag von Klemens am 13. Juni 2021, 01:38:04 »
...wenn du es "live" testen könntest und uns dann informierts.....

Super, und vielen Dank dafür.
Plugin in den RC1 Ver53 eingeladen. Keine Problem mit der Installation, keines mit sonstigen Fehlerhinweisen "in line xyz ... ".
Der Plugin-Reiter bleibt anwählbar.
Und es funktioniert inhaltlich wie es sein sollte.
Danach mit altem Plugin nochmal den Gegentest durchgeführt wieder mit beschriebenem Problem.
Dieses wieder gelöscht, die aktualisierte Version des Plugin eingespielt und wieder alles perfekt!
Nochmals vielen Dank. So kann dieses Plugin für und in V53 verwendet werden!

Gruß
Klemens
5
Betatests / Antw:moziloCMS 2.0 Rev53 RC1
« Letzter Beitrag von laborix am 12. Juni 2021, 20:04:45 »
Bitte lösche dein TermContent Plugin in deiner PHP 8 Testinstallation und ersetze es durch das an diesem Beitrag angehängte Plugin.

Da ich nur den Fehler im Admin Interface korrigiert habe, wäre es hilfreich wenn du es "live" testen könntest und uns dann informierts. Danke.

6
Betatests / Antw:moziloCMS 2.0 Rev53 RC1
« Letzter Beitrag von Klemens am 12. Juni 2021, 17:13:00 »
.... ist er nicht verpflichtet hierfür weiterhin Support oder etwas anderes leisten. Punkt.
Eventuell erklärt sich jemand  ....

Hallo Laborix,
bin ich dir zu nahe getreten? Sorry dafür!
Ich ging davon aus, das jemand, der ein Open-Source-Projekt final führt -wer das auch immer sein mag -  sowie all die anderen
die Ihren Einsatz hier gezeigt haben, ein Interesse haben könnten, dieses fortzusetzen.
Und wenn aus Sicht des Anwenders aktuell Probleme gesehen, ggf Lösungsansätze vermutet werden, dann sollte das doch möglich sein.
Mag ja auch sein, dass sich diese Problemsicht in Luft auflöst.
Solche  Meldungen sind und könnenn bei Open-Source kein personalisierter Auftrag sein. Schon klar!
Aber als einen Vorschlag für einen möglichen Punkt in der to - do -Liste darf es doch verstanden werden.   Als mehr sollte mein Beitrag nicht zu verstehen gewesen sein.

Gruß
Ks
7
Betatests / Antw:moziloCMS 2.0 Rev53 RC1
« Letzter Beitrag von laborix am 12. Juni 2021, 08:54:26 »
Hi Klemens,

moziloCMS ist OpenSource.

Somit hat niemand die Verpflichtung etwas Modernisieren/Weiterpflegen zu müssen, es ist freie Community Arbeit. Wenn jemand innerhalb der moziloCMS Community keine Ambitionen mehr für das moziloCMS Projekt hat, ist er nicht verpflichtet hierfür weiterhin Support oder etwas anderes leisten. Punkt.

Eventuell erklärt sich jemand mit freien Kapazitäten bereit ältere Plugins die nicht in der moziloCMS 2.0 Standard enthalten sind in seiner Freizeit auf PHP 8 zu portieren. Ansonsten muss jeder Anwender der solche Plugins einsetzt mit dieser Situation leben.

Gruß
8
Betatests / Antw:moziloCMS 2.0 Rev53 RC1
« Letzter Beitrag von Klemens am 11. Juni 2021, 19:45:45 »
Docu: hat nur kosmetische Änderungen welche keine Auswirkung auf Funktionalität haben
Plugins: Die Änderungen bei den bereits vorher vorhandenen Plugins sind im Changelog beschrieben.
Layouts: Die Änderungen sind auch im Changelog beschrieben.

hi Marust, sorry erst einmal dafür, dass ich nicht sofort auf deine Willkommen geantwortet habe. Das will ich hiermit gerne nachhohlen.
zu deinen Bemerkungen gem "Zitat".
Es überzeugt mich leider nicht, allein so vorzugehen. Befürchte, ihr seid dem selben Irrtum bezüglich PHP8 unterlegen, wie ich es war.

Es wird bis die Vers. 7.x bei den Providern abgeschaltet sein wird, sicher noch einige Zeit vergehen.
Doch genauso wird es eine Reihe von Usern geben, deren Provider eine aktuelle PHP-Version mit V8 bereit stellen.
Ihr seid vermutlich genötigt, in Folge der als nicht abwärtskompatibel deklarierten PHP8-Version Plugins etc doppelt vorzuhalten.


 
9
Betatests / Antw:moziloCMS 2.0 Rev53 RC1
« Letzter Beitrag von Klemens am 11. Juni 2021, 18:42:13 »

Edit
Ich habe gerade mal eine rev.51 mit PHP 7.3 auf rev.53 mit PHP 8.0.7 umgezogen .......

Hi Laborix,
Das Thema Schreibrechte hab ich überprüft und vorsichtshalber pauschal gesetzt. Soweit OK.
Der Zugriff auf den Reiter "Plugin" ist aber von anderen Dingen abhängig.
Habe den Ordner komplett geleert. >> Zugriff ok.
Dann mit euern "neuen " Plugins wieder gefüllt. >> ok
Dann aus der Rev51 das PHP-Plugin eingefügt: Überraschung, auch damit war der Zugriff möglich.
Anschließend das zweite verwendete Plugin eingefügt (TermContent) : Dieses Plugin führt dazu, dass in der Hauptanwendung der Reiter "Plugin" nicht mehr angesprochen werden kann.
Mit der im Vorpost bezeichneten Fehlerangabe.

Nun nahm ich mit meiner technischen Küchenphilosophie an, dass die PHP-Updates immer mit überschaubaren 
Veränderungen auch immer Abwärtskompatibel waren, und dies auch hier so wäre. Irrtum!
Musste auf der PHP-Seite lesen und feststellen, dass die Version 8 ein Major-Udate sei und explizit
darauf hingewiesen wird, dass die Abwärtskompatibilität nicht gegeben
wäre.

Nun bin ich kein Entwickler, evtl könnte man noch Patchworker zu den Fähigkeiten sagen.
Doch soweit konnte ich lesen, dass es offensichtlich ein Tool gäbe, welches bestehenden Code <Vers. 8
zügig in in eine Version 8 regelgeführt überträgt. Name: Rector (auf github verfügbar)
Ich hoffe, dass dies es euch ermöglicht, die bestehenden "alten" PHP-Dateien auf aktuellen Stand zu überführen
und den Anwendern diese wieder in neuer Version zur Verfügung zu stellen.

Und dennoch bleibt bei den Anwendern die Arbeit, die eigenen Veränderungen aus der bisherigen Version zur neuen Version nachzuvollziehen.
Dafür sollte mit den Updates ein überdeutlicher Hinweis auf diese Notwendigkeit erfolgen.
Es wäre auch zu überlegen, Mozilo allein wegen der Inkompatibilität von PHP8 zu den Vorgängerversionen ebenso eine neue Major-Release zu gönnen.
Berechtigt wäre es allemal, und würde die nicht kompatiblen Versionen voneinander trennen.
Damit würde die besondere Situation jedem überdeutlich.


10
Betatests / Antw:moziloCMS 2.0 Rev53 RC1
« Letzter Beitrag von Klemens am 10. Juni 2021, 23:21:32 »
Habt vielen Dank für eure Infos

Werde mir die Dinge in Ruhe ansehen.
Eines ist aber bereits zu bestätigen: eine Installation des RC1 auf PHP8.0.7 hat ohne Beanstandungen funktioniert.

Bin aber nicht der Meinung, dass ein Update wie dieses den Usern so ohne weiteres in die Hand gegeben werden kann. 
Die Zielgruppe von Mozilo ist doch der User, der ohne speziellen PHP / HTML oder sonstwelche Kenntnisse sich eine eigene Website erschließen kann /möchte.
So sollten fürs RC1 zumindest einige der am meisten gedownloadeten Plugins etc in einer Testumgebung verfügbar sein.
Und ja: kein Backup kein Mitleid. Und dennoch, eine Änderung von PHP-Versionen sollte in einem solchen Frontend nicht auf den User durchschlagen.

Wäre es zumindestens vorstellbar eine Routine bereitzustellen, dem der Mozilopfad übergeben wird und anhand der Kriterien im Changelog die kritischen Programmstellen markiert?

Solche User haben aber auch den Ehrgeiz, diese Vorlagen zu individualiseren. Man kann es auch als proklöppeln bezeichnen. Aber es ist doch legitim?!
Denke, dass ihr viele Problemreports erhalten werdet, falls die Provider schneller auf PHP8 wechseln.
Aber das ist nur so eine dumpfe Ahnung.
Ich werde mich in aller Ruhe den Dingen Schritt für Schritt annehmen, soweit die Zeit es erlaubt. Ihr werdet die Ergebnisse an diesem Ort finden.

@Laborix
werde mir auch deinen Post von 19:58 Uhr zur Hand nehmen und dazu detailiert Stellung nehmen. Werde mich zurück melden.

Bis dahin
Klemens

Wenn ihr euch vorab eine / die hier in Rede stehende  (die Nachfrage veranlassend) aktuell auf PHP7 und dem Mozillo Dark-Basis-Layout aufgebaute Applikation ansehen wollte,
ruft mal arsig.de auf. Dort hatte ich u.a. eine Accordionfunktion integriert.
Seiten: [1] 2 3 ... 10