Neueste Beiträge

Seiten: [1] 2 3 ... 10
1
ReHi!

! Erzeuge möglichst vorher via FTP ein Backup ... intern wird es nicht mehr funzen! !
Einfach Rev 52 ziehen ... den "Unkenrufen von damals" (<2020)  misstrauen .. weil die (ggf. vorhandenen 2.0 .conf Dateien -nicht überschrieben werden - weil sie bei einer Erstinstallation schlicht nicht vorhanden sind).
Wenn da, also keine "Gefahr".  Noch einmal :  "Worst Case" ....
(!) Individuelle Syntaxelemente sollten min. via CnP einfach gesichert werden.
Individuelle EMOS / "Smieles" sind weg -- sollten ggf. dann neu konfiguriert werden.

Ansonsten stehe ich weiterhin zu meiner damaligen Aussage:
Die drei Ordner cms , admin und docu sowie im ROOT die index.php via FTP "drüberbügeln" ....
Dann läuft es wieder.
Plugins wären ein neues Thema.

LG und viel Erfolg, melde Dich,
 wasp
2
Hallo amateur,

schau mal hier das sollte dir helfen
https://www.mozilo.de/forum/index.php/topic,4500.0.html
3
Danke fürs Interesse.
Installierte moziloCMS-Version 2.0 ("Amalia") Revision 50
Installierte PHP-Version 7.4.21

Und wenn ich auf den Inhalt, die eingerichteten Seiten, gehe und Änderungen vornehmen will, erscheint folgendes und ich werde aufgefordert, die Seite neu zu laden:
: Array and string offset access syntax with curly braces is deprecated in on line
 : Array and string offset access syntax with curly braces is deprecated in on line
: Array and string offset access syntax with curly braces is deprecated in on line
: Array and string offset access syntax with curly braces is deprecated in on line
Beim neuen Laden lande ich ein einer Schleife.
4
Hallo!
Schreib mal bitte welche Versionen im Tab "Info" nach dem Einloggen angezeigt werden:

1. CMS-Informationen (dritte Box)
Installierte moziloCMS-Version z.B. 2.0 ("Amalia") Revision 52
2. Server-Informationen / Voraussetzungen (vierte Box)
Installierte PHP-Version z.B. 7.4.21

> Diese Infos helfen bei der Ursachensuche sehr, vermutlich hat dein Provider auf eine neue PHP-Version umgestellt!

5
Bislang lief es mit Mozilo sehr gut und notwendige Anpassungen habe ich auch hinbekommen. Meine Website kann man immer noch aufrufen und lesen.
Wenn ich mich aber als admin anmelde, erscheint in den ersten Zeilen sofort der folgende Text, der mir aber auch gar nichts sagt.

Deprecated: Array and string offset access syntax with curly braces is deprecated in /homepages/19/d289765xxx/htdocs/cms/idna_convert.class.php on line 426

Deprecated: Array and string offset access syntax with curly braces is deprecated in /homepages/19/d289765xxx/htdocs/cms/idna_convert.class.php on line 440

Deprecated: Array and string offset access syntax with curly braces is deprecated in /homepages/19/d289765xxx/htdocs/cms/idna_convert.class.php on line 867

Deprecated: Array and string offset access syntax with curly braces is deprecated in /homepages/19/d289765xxx/htdocs/cms/idna_convert.class.php on line 998

Und sobald ich Änderungen am Inhalt vornehmen will, kommt wieder ein für mich unverständlicher Text, und nichts geht mehr.
Mache ich was falsch, obwohl beim letzten Ändern noch alles lief ?

Gibt es Hilfe ?
6
Plugins / Antw:2 verschiedene Probleme mit LangSwitch Plugin
« Letzter Beitrag von Tesla am 30. Juni 2021, 06:01:13 »
Ich  habe  alle  Fehler  behoben! Auch  bei  aktiviertem  Häkchen  "Versuche die Inhaltsseite(n) der anderen Sprache(n) zu finden"  funktioniert  LangSwitch bei mir  ohne  Fehler.
LangSwitch  zu  installieren ist  es schwerer, als  andere  Plugins, deshalb verdanke ich Ihnen für Ihre Zeit und Versuche.
Die  Ursache  war  falsche  Änderungen  in  Template.html. Ich hatte früher für die Sprachumschaltung i18n benutzt und mein Template.html dafür geändert. Nach der Deaktivierung der i18n Plugin, hatte ich alle Wörter "i18n"  in Template.html mit Langswitch ersetzt: das war die Ursache. Ich fand ein altes Backup von Mozilo bei mir, die ich vor dem Installation i18n gemacht hatte und wusste so die richtige (default) Kode des Templates. Ich füge 2 Bilder hinzu, die die nötige Kode erhalten.
 2 Fehler bei mir seien mit einander verbunden: jetzt bekomme ich wieder schöne Namen (statt CSS-Inhalt) im Browser Tab.
Hier kann man über Langswitch mehr erfahren:
http://www.stefanbe.de/meine%20Plugins/fürs%20Menu/LangSwitch.html
Dort  sind  die Anleitungen hilfreich, aber, meiner Meinung nach, nicht genug und nicht für jeder Anfänger geeignet. Wer dieses Plugin erstmals nutzt, kann in Screenshots sehen, wie ich LangSwitch in Template eingebaut habe.
Wichtig: alle diese Änderungen muss man in jeder Template jeder Sprache machen (mindestens im Fall, wenn man default Sprache statt Portalseite für Sprachwahl benutzt).
Dieses Plugin gibt einige Vorteile, z.B. unabhängige Layouts für jede Sprache!
7
Plugins / Antw:2 verschiedene Probleme mit LangSwitch Plugin
« Letzter Beitrag von marusti am 29. Juni 2021, 10:52:13 »
jetzt habe ich zumindest das Problem bei dir verstanden.
Allerdings scheine ich das Plugin selbst nicht zu verstehen (bei mir kommt immer die Default Seite wenn ich im Menü klicke (aber ohne Fehlermeldungen) auch wenn es die Seite in der anderen Sprache voranden ist), daher kann ich dir leider nicht weiterhelfen. Vielleicht nutzt jemand anderes das Plugin und kennt sich damit aus.
8
Plugins / Antw:2 verschiedene Probleme mit LangSwitch Plugin
« Letzter Beitrag von Tesla am 28. Juni 2021, 17:33:29 »
Vielen  Dank  für  Ihr  Versuch  und  Test!
Ich  nutze  2.0 ("Amalia")  Revision 51  und  PHP  7.3.7.

Ich  füge  noch 2 Fotos hinzu. Wenn ich  links im Menu auf  die  Name  jeder Inhaltsseite  klicke, sehe den oben genannten  PHP Fehler, wenn ich  nur  auf  die  Flagge  klicke um die Sprache zu wechseln, funktioniert alles normal.  Im anderen Bild ist sichtbar, wie CSS-Inhalt auf Browsertab sichtbar ist. Wenn ich den Mauszeiger auf dem Tab halte, sehe ich unten dem Tab ein schwarzes (temporäres) Rechteck, wo die noch längere CSS-Inhalt sichtbar ist (das konnte ich mit Screenshot nicht aufnehmen).
Es ist interessant, sind diese 2 Probleme mit auseinander verbunden?  Im Firefox auch gibt es dieselbe Fehler. Wenn ich im Browser eine Inhaltsseite aus dem zweiten Mozilo-CMS, das innerhalb erstes CMS im Sprachordner (z.B. en oder ru) installiert ist, aufrufe, gibt es dieselbe Fehler.  Ich nutze ein geändertes Layout, wo ich nur Bilder und Farben geändert habe und bis dieses Plugin hatte keine unlösbare Probleme.
Wenn jemand eine Ahnung hat, wo kann sich das Problem stecken, bitte schreiben und ich werde versuchen die Fehler aufzuheben.

9
Plugins / Antw:2 verschiedene Probleme mit LangSwitch Plugin
« Letzter Beitrag von marusti am 28. Juni 2021, 10:22:33 »
Hallo Tesla,
ich habe heute das Plugin zum ersten mal genutzt (von hier https://www.mozilo.de/forum/index.php/topic,4426.msg23387.html#msg23387 runter geladen) und konnte bisher keine Fehler sehen.
Welche Rev benutzt du und welche PHP Version?
10
Layouts / Layout MistyLook - Portiert von Wordpress
« Letzter Beitrag von laborix am 26. Juni 2021, 13:48:37 »
Ein etwas älteres Wordpress Layout, das ich schon eine ganze Weile auf moziloCMS 2.0 portieren wollte. Einfach gehalten, interessante Farbkombination, ohne Gimmicks, portiert nach HTML 5 und auf mobile Geräten einsetzbar.

Seiten: [1] 2 3 ... 10