Problem mit dem moziloCMS-CONTACT-Plugin

  • 7 Antworten
  • 134 Aufrufe
*

Offline hheigl

  • Mitglied
  • 74
Problem mit dem moziloCMS-CONTACT-Plugin
« am: 21. Februar 2021, 20:38:18 »
Von einem Kunden wurde ich darauf aufmerksam gemacht, dass sein Kontakt-Formular nicht funktioniert.
Nachdem sich dies bei einem Selbsttest meinerseits bestätigt hatte, habe ich habe ich alle möglichen Testversuche unternommen, um die Ursache zu erforschen.

Zunächstmal habe ich im Plugin alle entbehrlichen Zusatzfunktionen wie z.B. Spam-Aufgabe und die Checkbox Datenschutz deaktiviert.

Erst nachdem ich die beiden Häckchen bei Einzeiliges Textfeld "Betreff" herausgenommen habe, kam eine Nachricht an.

Solange beim Textfeld "E-Mail" das Kästchen "Kopie an diese senden" aktiviert ist, kommt zwar beim Absender eine Nachricht mit der Betreffzeile "Versandbestätigung ... " an, beim angegebenen Mailempfänger kommt jedoch keine Nachricht an.

Erst nachdem ich die Funktion "Kopie an diese senden" deaktiviert hatte, kam erstmals eine Nachricht beim Empfänger mit der Betreffzeile "Kontaktformular von ..." an.

Dieses Plugin-Verhalten ist in meinen Augen nicht akzeptabel!

Könnte da vielleicht mal ein Programmierer einen Blick auf das Plugin werfen und diese Fehler beheben?


PS:
Auf der Webseite wurde im Kontakt-Formular jedesmal der Versand bestätigt ("Die Nachricht wurde versendet!"), auch wenn dies nicht zutraf.
Beim Kunden ist die moziloCMS-Version 2.0, Revision 52 installiert; auf dem Server läuft die PHP-Version 7.3.27


*

Offline marusti

  • Administrator
  • Mitglied
  • 495
Antw:Problem mit dem moziloCMS-CONTACT-Plugin
« Antwort #1 am: 22. Februar 2021, 09:38:26 »
Ich hab das Mal auf die Schnelle auf einer Testseite versucht (alle Felder angeklickt und als erforderlich markiert) und bei mir hat alles funktioniert (Ich gehe davon aus, dass ihr auch im Spam geschaut habt).

Bei welcher Kombination jetzt genau geht es nicht - egal welche solange "Kopie" angeklickt ist? Oder muss auch "Betreff" nicht angeklickt werden?

*

Offline hheigl

  • Mitglied
  • 74
Antw:Problem mit dem moziloCMS-CONTACT-Plugin
« Antwort #2 am: 22. Februar 2021, 11:10:47 »
Hallo @marusti
Ja, im Spamordner haben wir auch nachgeschaut - war aber nichts enthalten.

Nachdem in der Empfängermail automatisch in der Betreffzeile der Text "Kontaktformular von ...(Name der Website)" und in der Mail an den Absender der Text
"Versandbestätigung: Kontaktformular ..." in die Betreffzeile eingefügt wird, hatte ich vermutet, es könnte womöglich ein Konflikt entstehen, wenn durch den Absender
in der Betreffzeile zusätzlich eine Eingabe erfolgt. Deshalb habe ich in den Plugineinstellungen die beiden Häckchen beim Textfeld "Betreff" herausgenommen,
damit keine (zusätzliche) manuelle Eingabe in dieser Zeile erfolgen kann.
Abzuklären wäre evtl. auch noch die Frage, ob die Einstellung "Ab wievielen Sekunden darf ein Besucher eine neue Nachricht über das Kontaktformular absenden können"
eine Auswirkung hat.  Zählt hier die Kopie an den Absender als "weitere Nachricht" und wird deshalb blockiert?

Ich habe mindestens 20 Testmails mit verschiedenen Kombinationen (mit mir selbst als abgespeicherten Mailempfänger) eingegeben, aber leider keine Systematik
herausfinden können, wann der Versand funktioniert und wann nicht. Das komische ist, dass einige Mails ankommen und beim nächsten Versuch wieder nicht.


*

Offline Mighty

  • Coder
  • Mitglied
  • 61
Antw:Problem mit dem moziloCMS-CONTACT-Plugin
« Antwort #3 am: 22. Februar 2021, 14:39:35 »
Ich habe auf meiner und einer anderen Website versucht den Fehler zu reproduzieren.
Bei Beiden Seiten funktioniert alles ohne Probleme, mit und ohne Mali an den Absender (und auch allen anderen kombinationen der Felder).
www.twinix.de // kostenlose Layouts / Templates für das moziloCMS

*

Offline hheigl

  • Mitglied
  • 74
Antw:Problem mit dem moziloCMS-CONTACT-Plugin
« Antwort #4 am: 23. Februar 2021, 09:00:14 »
Hallo @marusti, hallo @Mighty,
ich hätte eine Bitte an Euch:  Könntet ihr mir bitte die von Euch verwendete Testversion des CONTACT-Plugins zukommen lassen (am Besten als .zip)?
Dann würde ich meine Version deinstallieren und es mit Eurer Version mal versuchen. Herzlichen Dank schon mal im Voraus.

*

Offline marusti

  • Administrator
  • Mitglied
  • 495
Antw:Problem mit dem moziloCMS-CONTACT-Plugin
« Antwort #5 am: 23. Februar 2021, 09:48:57 »
Hallo hheigl,
ich hab die Standardversion aus Rev52 benutzt.

*

Offline hheigl

  • Mitglied
  • 74
Antw:Problem mit dem moziloCMS-CONTACT-Plugin
« Antwort #6 am: 23. Februar 2021, 18:42:46 »
Ich hab das Plugin deaktiviert und gelöscht.  Dann hab ich per FTP das Plugin aus der Revision 52 auf den Server hochgeladen und aktiviert.

Dann habe ich alle möglichen Testvariationen durchprobiert. Das Kontaktformular wird nur zugestellt, wenn in den Einstellungen im Feld
E-Mail bei "Kopie an diese senden" kein Häckchen gesetzt ist.
Sobald ich hier ein Häckchen setze, bekommt nur der Absender eine Versandbestätigungsmail - beim eingetragenen Empfänger kommt nichts an.
Ich kann es mir nicht erklären, woran das liegen kann.

*

Offline marusti

  • Administrator
  • Mitglied
  • 495
Antw:Problem mit dem moziloCMS-CONTACT-Plugin
« Antwort #7 am: 25. Februar 2021, 12:03:57 »
Hat jemand anderes das gleiche Problem?