Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2

  • 17 Antworten
  • 1428 Aufrufe
*

Offline Andreas B

  • Mitglied
  • 1
Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« am: 29. Oktober 2018, 14:54:03 »
Hallo zusammen,
mein Provider verlangt eine Umstellung auf PHP 7.2.11. Es funktioniert soweit alles prima, bis auf das Plugin Calendar. Folgender Fehlermeldung wird auf der Webseite formatfüllend angezeigt, sobald eine Datenbank angelegt wurde:

Warning: count(): Parameter must be an array or an object that implements Countable in C:\xampp\htdocs\Lauftreff-Grebenstein.de\plugins\Calendar\pattern\dates.php on line 107

Calender-Version 11
Mozilo-Version 2. rev50

Wenn jemand helfen könnte, wäre ich wirklich dankbar.
Gruß
Andreas

*

Offline rolinux

  • Mitglied
  • 664
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #1 am: 29. Dezember 2018, 18:59:14 »
Hallo,

ich wollte grade anfangen, für einen Verein die Termine des nächsten Jahres eintragen.
Wenn ich im Backend auf "Verwalten" klicke und mir die Kalender angezeigt werden, kommt die Fehlermeldung:
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; CalAdmin has a deprecated constructor in /var/www/ud18_368/html/bdc/plugins/Calendar/admin/index.php on line 12
Ich habe mir gedacht, dass ich das hier mit reinhänge, dann kann man das vlt. am Stück bearbeiten.

Nachtrag: Es fehlen einige Symbole im Calendar-Backend: Alle markieren, Auswahl Datum/Uhrzeit und anderes, an das ich mit jetzt grade nicht erinnern kann.
Termine kann ich erfassen.

Gruß
Rolf
« Letzte Änderung: 29. Dezember 2018, 19:07:05 von rolinux »
"Vergiss nie, dass die Musik viel zu wichtig ist,
um sie ganz den Profis zu überlassen."
(Robert Fulghum, amerikanischer Philosoph)

*

Offline rolinux

  • Mitglied
  • 664
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #2 am: 10. Januar 2019, 19:51:15 »
Wann können wir mit der Behebung der Fehler rechnen? Auch in den anderen Plugins? php 7 ist ja jetzt schon eine Weile auf dem Markt und php 5.6 ist schon oder wird (je nach Hoster) definitiv abgeschaltet.

Es ist mir schon klar, dass diese ganzen Plugins und auch moziloCMS selber unentgeltlich programmiert und gepflegt werden. Aber das habe ich bei anderen CMS auch und trotzdem kommen regelmäßig Updates (die werden je nach CMS sogar im Backend gemeldet und können da direkt installiert werden).

Es ist ärgerlich, wenn ich für Vereine und kleine Firmen aus meinem Bekanntenkreis Homepages erstelle und die sich darauf verlassen, dass das funktioniert und dann funktionierts eben nicht so. Das schadet dem Ruf von moziloCMS schon sehr, meine ich. Ich bin nach wie vor ein großer Fan von moziloCMS und werde es nach Möglichkeit immer einsetzen. Es ist ein einfaches und übersichtliches CMS mit großen Möglichkeiten.

Ich habe selber zwar Ahnung vom Programmieren, aber halt nicht von php, und habe auch keine Zeit, mir php nebenher beizubringen. Sonst könnte ich die Probleme und Fehler vlt. selber beheben.

Herzliche Grüße
Rolf
"Vergiss nie, dass die Musik viel zu wichtig ist,
um sie ganz den Profis zu überlassen."
(Robert Fulghum, amerikanischer Philosoph)

*

Offline Rainer

  • Administrator
  • Mitglied
  • 710
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #3 am: 13. Januar 2019, 10:23:41 »
Servus rolinux,

Änderungen an den Plugins wird es nur dann geben wenn sich jemand mit der nötigen freien Zeit und dem entsprechenden Wissensstand hinsetzt und die Arbeit für die Anderen macht. Falls du also jemanden kennst oder denkst jemand könnte jemanden kennen: fragen ob es die Person vielleicht machen würde.

Grüße Rainer
« Letzte Änderung: 13. Januar 2019, 10:26:23 von Rainer »
moziloCMS bei Diaspora*
•• moziloCMS über Facebook bekannt machen
••• moziloCMS auf GitHub
•••• Nichts ist einfacher, als das, was uns fremd ist, zu verachten.
••••• Mein moziloCMS

*

Offline rolinux

  • Mitglied
  • 664
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #4 am: 13. Januar 2019, 12:17:38 »
Eigentlich dachte ich, dass vor allem der Programmierer eines Plugins dafür verantwortlich ist, dass das Plugin korrekt funktioniert und nicht die Anwender. Es war mir nicht bewusst, dass die Plugin-Programmierer hier ihre Ideen einfach reinschmeißen und dann die Sintflut. Das ist keine gute Werbung für das CMS.

Die Idee von moziloCMS ist doch die, dass man auch ohne Kenntnisse in HTML, CSS, Datenbanken und anderem Homepages machen kann. Das ist mit dieser Vorgehensweise aber nicht möglich. Denn wenn ich nur das Basis-CMS nutzen kann und die Plugins (die ja auch auf der mozilo-Homepage beworben werden) nicht benutzen kann, weil sie nicht an die modernen Gegebenheiten (in diesem Fall php7) angepasst werden, dann wird moziloCMS nicht mehr lange existieren.

"Vergiss nie, dass die Musik viel zu wichtig ist,
um sie ganz den Profis zu überlassen."
(Robert Fulghum, amerikanischer Philosoph)

*

Offline marusti

  • Administrator
  • Mitglied
  • 378
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #5 am: 14. Januar 2019, 10:54:53 »
Eigentlich dachte ich, dass vor allem der Programmierer eines Plugins dafür verantwortlich ist, dass das Plugin korrekt funktioniert und nicht die Anwender.
Das ist absolut korrekt, so sollte es auch sein. Allerdings sind die zusätzlich herunterladbaren Plugins (genau wie die Layouts) von verschiedenen Drittanbietern erstellt worden. Das Prinzip ist das Gleiche wie bei jedem anderen Open Source CMS auch (auch dort werden Funktionen als Standard bereit gestellt und Drittanbieter erstellen weitere Funktionen/Plugins/Layout).  Viele schaffen es leider aus zeitlichen Gründen nicht mehr sich mit mozilo zu beschäftigen. Und genau da kommt die Idee der OpenSource Community ins Spiel, dass sich auch andere an der Programmierung beteiligen können. Leider scheint die mozilo Community aktuell nicht sehr aktiv (auch hier kann ich das selbst aus Zeitgründen absolut nachvollziehen), da müssen wir uns aber alle selbst an die Nase fassen  8)

*

Offline bemerkenswelt

  • Mitglied
  • 180
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #6 am: 14. Januar 2019, 18:09:12 »
Eigentlich dachte ich, dass vor allem der Programmierer eines Plugins dafür verantwortlich ist, dass das Plugin korrekt funktioniert und nicht die Anwender. ..... ihre Ideen einfach reinschmeißen und dann die Sintflut. ...
Auch ich bin auch sehr traurig darüber, dass mozilo im Prinzip tot zu sein scheint, aber möchte zu diesem Gepräch trotzdem sagen:

Den Entwicklern "reinschmeißen und Sintflut" vorwerfen ist unfair. Als junge Menschen hatten sie Zeit und Spaß daran das zu programmieren und der Allgemeinheit zur Verfügung zu stellen. Dass die meisten jetzt mittlerweile so in ihr Arbeits- und vielleicht auch Familienleben eingebunden sind, dass sie keine Zeit mehr dafür aufbringen können, ist zwar schade, aber niemandem vorzuwerfen. So nett zu sein und der Community ein Plugin zu programmieren, kann nicht bedeuten ein Leben lang dazu verdonnert zu sein, es auf dem neuesten Stand zu halten. Plugins kommen und gehen und bei solch einem open source Projekt sollten eigentlich auch die Programmierer frei kommen und gehen können. Das Unglück von mozilo ist, dass sich - warum auch immer - keine neuen, jungen Leute finden, die Spaß daran haben an mozilo weiter zu arbeiten und die Stelle der alten einzunehmen.

Ich fand es auf jeden fall toll, wie in letzter Zeit doch noch einige der Alten Ihre Energie und Zeit in die Aktualisierung von Plugins und die Entwicklung schöner neuer Layout-Templates gesteckt haben.
Vielen, vielen Dank.
Schöne Grüße
Manfred

Besucht mich auf: www.bemerkenswelt.de

*

Offline Rainer

  • Administrator
  • Mitglied
  • 710
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #7 am: 16. Januar 2019, 13:40:01 »
Zu den Entwicklern, denen, aus welchen Gründen  auch immer, die Zeit fehlt, sich anderweitige Arbeitsfelder gesucht haben oder was auch immer, muss ich nichts mehr sagen. Das haben Marusti und bemerkenswelt schon getan.
Ich versuche, so gut es geht, alle Bekannten darauf anzusprechen, wer Programierkenntnisse hat oder jemanden mit solchen kennt. Das kann ich allen hier mitlesenden auch empfehlen.
Vielleicht ist es ja auch Hilfreich, zu sagen: hey, ich bräuchte genau so ein Plugin und suche jemanden wo mir das Dingens (OpenSource) schreibt/umschreibt. Ich gebe gerne ??,- € dafür. Vielleicht will sich auch noch jemand an der Entlohnung beteiligen ......

Im Endeffekt kostet alles irgend was. Ob Zeit oder Geld. Leider ist es für viele im Netz zur Gewohnheit geworden die Angebote mit zu nehmen und sich über irgendwelche Kosten keine oder kaum Gedanken zu machen.

Grüße Rainer
moziloCMS bei Diaspora*
•• moziloCMS über Facebook bekannt machen
••• moziloCMS auf GitHub
•••• Nichts ist einfacher, als das, was uns fremd ist, zu verachten.
••••• Mein moziloCMS

*

Offline marusti

  • Administrator
  • Mitglied
  • 378
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #8 am: 16. Januar 2019, 23:11:20 »
Zurück zum eigentlichen Thema
Zitat
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; CalAdmin has a deprecated constructor in /var/www/ud18_368/html/bdc/plugins/Calendar/admin/index.php on line 12

Änder Mal function CalAdmin($settings) in public function __construct($settings)

*

Offline marusti

  • Administrator
  • Mitglied
  • 378
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #9 am: 19. Januar 2019, 21:54:37 »
Aber das habe ich bei anderen CMS auch und trotzdem kommen regelmäßig Updates (die werden je nach CMS sogar im Backend gemeldet und können da direkt installiert werden).
So?

*

Offline rolinux

  • Mitglied
  • 664
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #10 am: 22. Januar 2019, 14:21:22 »
Aber das habe ich bei anderen CMS auch und trotzdem kommen regelmäßig Updates (die werden je nach CMS sogar im Backend gemeldet und können da direkt installiert werden).
So?

Wird bei mir in mozilo nicht gezeigt. Und ich habe die Revision 51 installiert.
"Vergiss nie, dass die Musik viel zu wichtig ist,
um sie ganz den Profis zu überlassen."
(Robert Fulghum, amerikanischer Philosoph)

*

Offline marusti

  • Administrator
  • Mitglied
  • 378
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #11 am: 22. Januar 2019, 14:30:59 »
Wird bei mir in mozilo nicht gezeigt. Und ich habe die Revision 51 installiert.
Das  war als Vorschlag gemeint ob du sowas in der Art meinst? Wie du richtig festgestellt hast, gibt es das aktuell nicht. Die Screenshots sind aus einer Testumgebung.

*

Offline rolinux

  • Mitglied
  • 664
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #12 am: 22. Januar 2019, 15:14:52 »
Ach so. Ich dachte schon, da funktioniert noch was nicht...
So eine Anzeige fände ich gut.
"Vergiss nie, dass die Musik viel zu wichtig ist,
um sie ganz den Profis zu überlassen."
(Robert Fulghum, amerikanischer Philosoph)

*

Offline rolinux

  • Mitglied
  • 664
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #13 am: 18. Februar 2019, 17:31:37 »
Zurück zum eigentlichen Thema
Zitat
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; CalAdmin has a deprecated constructor in /var/www/ud18_368/html/bdc/plugins/Calendar/admin/index.php on line 12

Änder Mal function CalAdmin($settings) in public function __construct($settings)

So, jetzt bin ich endlich mal dazu gekommen, das zu testen.
Ergebnis: Das Layout der Kalenderverwaltung ist etwas schöner und die Fehlermeldung ist weg. Soweit also schon mal gut. Vielen Dank.

Die Funktionssymbole zum Eintragen der Termine (z.B. Datums- und Uhrzeitauswahl) fehlen immer noch, aber das lässt sich verschmerzen, wenn man weiß, wie die Syntax von Datum und Uhrzeit sein muss. Wäre aber schön, wenn dazu noch jemand eine Idee hätte.

Gruß
Rolf
"Vergiss nie, dass die Musik viel zu wichtig ist,
um sie ganz den Profis zu überlassen."
(Robert Fulghum, amerikanischer Philosoph)

*

Offline marusti

  • Administrator
  • Mitglied
  • 378
Re: Plugin Calendar: Fehlermeldung nach Umstellung auf PHP 7.2
« Antwort #14 am: 19. Februar 2019, 12:47:40 »
Bei mir schaut es so aus (Calendar Plugin Rev2) mit PHP 7.2.5
« Letzte Änderung: 19. Februar 2019, 12:49:41 von marusti »