moziloCMS 1.12.php7 - das "alte" moziloCMS für PHP7

  • 3 Antworten
  • 712 Aufrufe
*

Offline azett

  • Coder
  • Mitglied
  • 2401
moziloCMS 1.12.php7 - das "alte" moziloCMS für PHP7
« am: 10. September 2017, 13:36:57 »
Hallo zusammen,

da das Thema hier im Forum schon einige Male aufgetaucht ist, habe ich mich mal rangesetzt und Version 1.12 in ihrem letzten Stand fitgemacht für PHP7. Ich war so frei, das Ganze "moziloCMS 1.12.php7" zu nennen.

Download: https://github.com/azett/mozilo1/archive/master.zip

Wer sichs im Detail schauen möchte, das ist mein Fork bei GitHub: https://github.com/azett/mozilo1

Bitte testet es mal und lasst mich hier wissen, ob alles sauber auch unter PHP7 läuft.  Danke! :)

Beste Grüße
Arvid

*

Offline azett

  • Coder
  • Mitglied
  • 2401
Re: moziloCMS 1.12.php7 - das "alte" moziloCMS für PHP7
« Antwort #1 am: 12. Mai 2018, 12:47:35 »
Ich habe moziloCMS 1.12.php7 nun auch auf meiner Website dokumentiert: https://www.arvidzimmermann.de/index.php?cat=moziloCMS%201.12.php7

*

Offline azett

  • Coder
  • Mitglied
  • 2401
Re: moziloCMS 1.12.php7 - das "alte" moziloCMS für PHP7
« Antwort #2 am: 22. September 2018, 18:14:44 »
Hallo zusammen,

ich habe in moziloCMS 1.12.php7 noch ein paar Fehler behoben. Mir sind aktuell keine weiteren Bugs bekannt, ich setze diesen Stand problemlos unter PHP 7.2 ein.

Download als ZIP: https://github.com/azett/mozilo1/archive/master.zip
Repository bei GitHub: https://github.com/azett/mozilo1/

Beste Grüße
Arvid

*

Offline Karsten Meyer

  • Mitglied
  • 84
Re: moziloCMS 1.12.php7 - das "alte" moziloCMS für PHP7
« Antwort #3 am: 18. Oktober 2018, 21:25:30 »
Vorab sehr herzlichen Dank für die Anpassungen der alten Version, Arvid.

Ich habe mit Mozilo 1.12.beta4 ("Amalia") Revision 866 seit 2011 ein Web laufen, das ich vorerst gern so belassen würde, aber hosteurope wird in ein paar Tagen PHP 5.6 abschalten.

Jetzt hab ich lokal (XAMPP mit PHP 7.2) probiert, einfach alle PHP-Dateien gegen die "neuen" vom 22.9. auszutauschen, das bringt leider folgende Ausgabe:
Warning: Use of undefined constant BASE_DIR_CMS - assumed 'BASE_DIR_CMS' (this will throw an Error in a future version of PHP) in D:\XAMPP\htdocs\FCMS-2015-09-12\cms\Language.php on line 24

Warning: Use of undefined constant BASE_DIR_CMS - assumed 'BASE_DIR_CMS' (this will throw an Error in a future version of PHP) in D:\XAMPP\htdocs\FCMS-2015-09-12\cms\Language.php on line 27

Warning: Use of undefined constant BASE_DIR_CMS - assumed 'BASE_DIR_CMS' (this will throw an Error in a future version of PHP) in D:\XAMPP\htdocs\FCMS-2015-09-12\cms\Plugin.php on line 14

Warning: require_once(BASE_DIR_CMSSyntax.php): failed to open stream: No such file or directory in D:\XAMPP\htdocs\FCMS-2015-09-12\cms\Plugin.php on line 14

Fatal error: require_once(): Failed opening required 'BASE_DIR_CMSSyntax.php' (include_path='D:\XAMPP\php\PEAR') in D:\XAMPP\htdocs\FCMS-2015-09-12\cms\Plugin.php on line 14

Da sich alles um dieses "BASE_DIR" dreht, habe ich Hoffnung, dass sich das ohne größeren Aufwand beheben lässt. Darf ich mit Hilfe rechnen? Das wäre großartig.

Oder gibt es einen "offiziellen" Weg, das als Update zu installieren?

Schönen Gruß
Karsten