forum.mozilo.de das Supportforummozilo Forum
Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?

Einloggen mit Benutzername, Passwort und Sitzungslänge

Beiträge anzeigen

Diese Sektion erlaubt es ihnen alle Beiträge dieses Mitglieds zu sehen. Beachten sie, dass sie nur solche Beiträge sehen können, zu denen sie auch Zugriffsrechte haben.


Themen - laborix

Seiten: [1] 2 3 4
 
1
Hallo miteinander,

wenn man in Mozilo 2.0 (aktuelle Github Version) im Kontaktformular weder Pflichtfelder noch eine Spamschutz Abfrage aktiviert, wird nach einem Klick auf "Senden" ein leeres Kontaktformular gesendet.

Eigentlich sollten die Felder vor dem Senden auf Inhalte abgefragt werden. Auf der anderen Seite, wer außer einem Tester sendet ein leeres Formular  :)

Gruß
Laborix

 

 
 
2
Hallo miteinander,

wenn ich in der aktuellen Github moziloCMS 2.0 eine Inhaltsseite bearbeite, dann speichere und dem Admin-Bereich ganz offiziell schließe, kann man durch Klick auf die Weltkugel die Website anschauen. Klappt wunderbar, als kein Funktionsfehler.

Aber in der URL steht http://w....irgend...eine...domain.d...e/index.php?draft=true

Warum draft=true? Ich habe alles gespeichert und mich offiziell abgemeldet. Eventuell Rubrik Schönheitsfehler?

 
 
3
Hallo miteinander,

wenn man eine Inhaltsseite bearbeitet und dort nach einer Überschrift zwei Leerzeichen anfügt, also hinter der schließenden eckigen Klammer
[ueber3|Überschrift H3]   <- Leerzeichen, 2 Stück.
dolor sit amet, consectetuer adipiscing elit. Aenean commodo ligula eget dolor. Aenean massa. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Donec quam felis, ultricies nec, pellentesque eu, pretium quis, sem.
wird automatisch folgender HTML-Code generiert:
<h3 id="a5" class="heading3">Überschrift H3</h3>&nbsp;&nbsp;<br />
dolor sit amet, consectetuer adipiscing elit. Aenean commodo ligula eget dolor. Aenean massa. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Donec quam felis, ultricies nec, pellentesque eu, pretium quis, sem.
ganz kurios ;) , aber reproduzierbar mit der aktuellen Github moziloCMS 2.0 und PHP 5.6. Ist übrigens egal, ob H1, H2, H3 oder H4.

 
 
4
Hallo,

muss ich wohl beim letzten Testen übersehen haben. Wenn man in die moziloCMS Dokumentation geht, dann kommt folgender PHP 7.0.7 Fehler:
Zitat
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; moziloDocuClass has a deprecated constructor in .../mozilo20/docu/docuClass.php on line 6

Testserver: Apache 2.2.31 64bit, PHP 7.0.7 NTS 64bit und moziloCMS 2.0 Github 29. Mai 2016

Gruß

 

 
 
5
Hier klemmt es! / HTML Fehler in der Standard Galerie
« am: 28. Mai 2016, 13:06:32 »
Hallo,

der HTML-Validator wirft bei einer Standard Galerie im moziloCMS 2.0 (letzte Github Version) folgenden Fehler:
Zitat
W3C Validator
an attribute value literal can occur in an attribute specification list only after a VI delimiter
 
Wenn eine Galerie (Standard) eingebunden wird und die Vorschaubilder angezeigt werden, dann hat der HTML Validator ein Problem mit dem aus dem Standard moziloCMS Plugin Galerie erzeugten HTML Code:

<td class="gallerytd" style="width:50%;">
  <a href="/galerien/Bilder/bild-1.jpg" target="_blank" title="Vollbildanzeige: "bild-1.jpg"">
    <img src="/galerien/Bilder/vorschau/bild-1.jpg" alt="bild-1.jpg" class="thumbnail" />
  </a>
  <br />
  Ein Bild
</td>
Beim Bildtitel mit target=blank und dem Text Volbildanzeige werden beim Bildnamen.jpg zwei zusätzliche Hochkommatas um den Bildnamen angegeben, was den Fehler im HTML-Validator verursacht.

Der zuständige Code liegt in plugins\Galerie\index.php in der Zeile 249 zu finden. Da ich keine Ahnung habe in wie weit eine Anpassung dieser Zeile im mozilo Core etwas durcheinander bringt, beziehungsweise noch woanders würde ich mich über eine Info, beziehungsweise Korrektur freuen.


 

 
 
6
Hallo miteinander,

habe gerade mein Apache Webserver auf PHP 7.0.2 aktualisiert und die mozilo 2.0 V49 Github Version vom 17. Januar 2016 auf Error_Reporting E_ALL gepatcht. Die Installation vom mozilo 2.0 läuft ohne Probleme durch, aber im Apache access.log tauchen folgende 404er Einträge auf?

::1 - - [19/Jan/2016:19:42:50 +0100] "POST /mozilo20/install/xy/test.php HTTP/1.1" 404 226
::1 - - [19/Jan/2016:19:42:50 +0100] "POST /mozilo20/install.php HTTP/1.1" 200 39
::1 - - [19/Jan/2016:19:42:50 +0100] "POST /mozilo20/install/xy/test.php HTTP/1.1" 404 226
::1 - - [19/Jan/2016:19:42:50 +0100] "POST /mozilo20/install.php HTTP/1.1" 200 39
::1 - - [19/Jan/2016:19:42:51 +0100] "POST /mozilo20/install/xy/test.php HTTP/1.1" 404 226
 
Das ganze 10x?

Kann es sein das in der Github mozilo 2.0 V49 noch was auf Debug-Modus steht?


LG
Laborix

 
 
7
Ich wünsche mir... / mozilo20 - Standard Kontakt Forumlar
« am: 24. Dezember 2015, 17:33:24 »
Hallo miteinander,

ich stelle hier mal was zu Diskussion :)

Das Standard Kontakt Plugin hat folgende Reihenfolge:

  • Name
  • Website
  • E-Mail
  • Nachricht

Ich ändere die Reihenfolge jedesmal im Plugin-Code auf:

  • Name
  • E-Mail
  • Website
  • Nachricht

da ich die Website als optionale Angabe eintrage, siehe Beispiel:

  • Ihr Name
  • Ihre E-Mail Adresse
  • Ihre Website (optional)
  • Ihre Nachricht

Wäre eine Reihenfolge Änderung sinnvoll oder nicht. Ich bitte um eure Meinungen.


LG
Laborix

 
 
8
Hier klemmt es! / mozilo20 - Standard Galerie - Admin Inhaltsseiten
« am: 24. Dezember 2015, 17:23:51 »
Hallo miteinander,

akutelle Github Version mozilo20, PHP Version egal. Aktiviertes Standard Galerie Plugin mit korrekten Einstellungen.

Wenn ich im mozilo20 Admin eine neue Inhaltsseite anlege und dann im Bearbeiten-Modus in der Galerien Listbox "moziloCMS" auswähle, erscheint im Editor:
@=moziloCMS=@
Korrekt wäre doch eigentlich
{Galerie|moziloCMS}
Lässt sich das irgendwie ändern?


LG
Laborix

 
 
9
Hier klemmt es! / mozilo20 und PHP 7
« am: 13. Dezember 2015, 13:03:49 »
Hallo miteinander,

wenn man mozilo20 unter PHP 7 installiert hat und dann in den Admin-Bereich wechseln will, kommt:
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Properties has a deprecated constructor in /dev/mozilo20/cms/Properties.php on line 3

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; SpecialChars has a deprecated constructor in /dev/mozilo20/cms/SpecialChars.php on line 11

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Language has a deprecated constructor in /dev/mozilo20/cms/Language.php on line 3

Warning: Cannot modify header information - headers already sent by (output started at dev/mozilo20/cms/Properties.php:3) in /dev/mozilo20/admin/index.php on line 275

Hat man es bis zum Admin Panel geschafft, kommt gleich noch mehr:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Properties has a deprecated constructor in /dev/mozilo20/cms/Properties.php on line 3

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; SpecialChars has a deprecated constructor in /dev/mozilo20/cms/SpecialChars.php on line 11

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Language has a deprecated constructor in /dev/mozilo20/cms/Language.php on line 3

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; PasswordHash has a deprecated constructor in /dev/mozilo20/cms/PasswordHash.php on line 27

Warning: Cannot modify header information - headers already sent by (output started at /dev/mozilo20/cms/Properties.php:3) in /dev/mozilo20/admin/index.php on line 130

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; CatPageClass has a deprecated constructor in /dev/mozilo20/cms/CatPageClass.php on line 13

Das Frontend scheint aber ohne "Deprecated" zu laufen. Werde das aber noch austesten.


Gruß
Laborix

 
 
10
Hallo miteinander,

ein kleiner Schönheitsfehler in der aktuellen Github mozilo20 Version. Wenn man nach der Installation die sicherheitsrelevante Dateien löscht, erscheint oben in grün "...alles gelöscht..." und gleich darunter "...sicherheitsrelevante Dateien löschen...". Wenn man diesen Vorgang mit dem Löschen wiederholt, kracht es und ein HTTP 404-Fehler kommt.

Ist es nicht besser nach dem erfolgreichen Löschen der sicherheitsrelevanten Dateien die Löschfunktion zu entfernen?

Gruß
Laborix

 
 
11
Hallo miteinander,

Betriebssystem Windows 10 mit Microsoft Edge, moziloCMS 2.0 (fast) aktuelle Github Version 20.10.2015. Eine Website beim Provider mit PHP 5.6.

Wenn ich in eine vorhandene Galerie mit dem Microsoft Edge Browser eine Grafik hochladen will, kommt der Dialog zum Auswählen der Grafik (normale .jpg Bilddatei). Nach dem Klick auf OK passiert nichts. Es sind etwa 10 Grafiken in dieser Galerie, die neue wird weder angezeigt, noch hochgeladen und ist einfach nicht da. Das gleiche mit einem anderen Internet Browser funktioniert.

Ist beim Standard Galerie Uploader von Mozilo 2.0 irgendetwas was den Microsoft Edge Browser stören kann? Ich habe keine Erklärung hierfür.

Gruß Laborix

 
 
12
Wie kann ich...? / Error_Reporting strict aktivieren
« am: 20. Oktober 2015, 13:25:46 »
Hallo miteinander,

PHP 7 steht kurz vor der Final Relase und es wäre interessant dann schon mal zu wissen wo es im MoziloCMS 2.0 klemmt (falls es klemmen sollte).

Wo und an welchen Stellen kann/muss man in MoziloCMS 2.0 das Error_Reporting aktivieren um das volle PHP Error Reporting zu bekommen?

Gruß

 
 
13
Hier klemmt es! / mozilo 2.0 und PHP 5.6
« am: 22. November 2014, 14:21:19 »
Hallo miteinander,

wenn mozilo 2.0 (Github Version 16.11.2014) mit PHP 5.6 ausgeführt wird und man in der Suche das Wort "willkommen" eintippt, erscheint folgender Fehler:

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in ...\htdocs\mozilo20\cms\SearchClass.php on line 248
Das Trefferergebnis wird aber mit wie gewohnt angezeigt. Ist beim ersten Schnelltest mit PHP 5.6 aufgefallen.

Fast vergessen  ::)
Der Fehler erscheint nur dann, wenn man in der index.php das "error_reporting(E_ALL);" aktiviert. Zum Live Test manuell bei mir eingebaut.

 
 
14
Hier klemmt es! / Template bearbeiten, Speichern Timeout, Rauswurf
« am: 28. September 2014, 11:44:51 »
Hallo,

Einsatz von moziloCMS 2.0 aktuelle Github Version, PHP 5.4 und SeaMonkey 2.29.1. Angemeldet als einzigster Admin und beim CSS bearbeiten eines eigenen Layouts.

Um Responsive Webdesign Layout zu testen habe ich das Smartphone nebendran liegen und lade die Testseite nach Änderungen auf dem Webspace. Wenn ich dann etwas länger teste oder schnell in Google was nachschlage (unter 5 Minuten) ist ein Speichern der Änderungen am CSS nicht mehr möglich. Der Dialog schließt nur dann wenn ich abbreche, ansonsten läuft der endlos.
Nach dem Abbruch fliege ich aus dem CMS und muss erst einmal alle anderen Logins aufheben. Das ist beim Online Testen mit mehreren mobilen Geräten ziemlich ärgerlich.

Gut, mir eigentlich egal, man kann damit leben, sind halt ein paar Klicks mehr.

LG

 
 
15
Betatests / mozilo 2.0 GitHub 30.10.2013
« am: 31. Oktober 2013, 15:41:48 »
Hallo miteinander,

zwei Dinge bekomme ich mit der aktuellen mozilo 2.0 nicht auf die Reihe. Wie kann man für Bilder in der mozilo 2.0 Standard Galerie den Untertitel ändern? In der mozilo 1.0 geht das wunderbar  :(

Nachdem ich mal wieder ohne IE, FF und Chrome unterwegs war, haben bearbeitete Inhaltsseiten Schwierigkeiten mit &lt;/&gt. Selbst wenn es im "html" enthalten ist. Nimmt man wieder einen Standard Browser geht es?

Getestet K-Meleon 1.6b2 unter Win / 32bit. Korrekturen mit IE 10 Win / 32bit gleiche Maschine.

 
Seiten: [1] 2 3 4