forum.mozilo.de das Supportforummozilo Forum
Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?

Einloggen mit Benutzername, Passwort und Sitzungslänge

Autor Thema: Wiki-Syntax [code] wird nicht interpretiert  (Gelesen 3474 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

 

Offline DasFaultier

  • Mitglied
  • *
  • Beiträge: 2
    • Profil anzeigen
    • http://thefaultier.th.funpic.de/moziloWiki/index.php
Wiki-Syntax [code] wird nicht interpretiert
« am: 29. September 2009, 20:01:32 »
Hi allerseits,

ich hab' mir heute das Mozilo-Wiki installiert und bin bisher sehr zufrieden. Jetzt ist allerdings das Problem aufgetaucht, dass ich gerne C#-Code in einen Wiki-Eintrag einfügen will. Dafür habe ich [code|meinCodeHier] benutzt, aber scheinbar wird Befehl nicht interpretiert, so dass dann auch der [code]-Befehl mit im Wiki-Eintrag zu lesen ist, dafür aber die Formatierung als Quellcode nicht klappt. Mache ich irgendwas falsch? Auf Anfrage kann ich natürlich gerne den betr. Eintrag verlinken / posten.

Vielen Dank im Voraus, euer
Faultier

Nachtrag: sonstige Formatierungen klappen tadellos, soweit ich das bisher feststellen konnte (Aufzählungen, Verlinkungen, Überschriften).
« Letzte Änderung: 01. Januar 1970, 01:00:00 von Guest »
 

 

Offline azett

  • Coder
  • Mitglied
  • ****
  • Beiträge: 2396
  • mozilo-Coder a.D.
    • Profil anzeigen
    • arvidzimmermann.de
Re: Wiki-Syntax [code] wird nicht interpretiert
« Antwort #1 am: 30. September 2009, 07:26:45 »
Hallo in die Heimat und willkommen im Supportforum :)

Du hast ganz sicher eckige Klammern innerhalb des Codes (z.B. beim Zugriff auf Arrayelemente: array[0]). Diese müssen mit einem vorangestellten Hochdach notiert werden (Details).
Nimm deinen Quellcode in den Texteditor deiner Wahl und ersetze mit der Suchen-/Ersetzen-Funktion
  • alle [ durch ^[
  • und alle ] durch ^]
Das Ergebnis fügst du dann in dein Code-Tag ein:
[code|array^[0^]]
« Letzte Änderung: 01. Januar 1970, 01:00:00 von Guest »
 

 

Offline DasFaultier

  • Mitglied
  • *
  • Beiträge: 2
    • Profil anzeigen
    • http://thefaultier.th.funpic.de/moziloWiki/index.php
Re: Wiki-Syntax [code] wird nicht interpretiert
« Antwort #2 am: 30. September 2009, 20:55:18 »
Ah, vielen Dank, ich dachte, dass dann mindestens der Text bis zur ersten schließenden Klammer korrekt dargestellt werden müsste. Ich hab's jetzt umformatiert und es klappt alles wunderbar, vielen Dank!

Liebe Grüße!

(bist du etwa auch DDer? ^^)
« Letzte Änderung: 01. Januar 1970, 01:00:00 von Guest »
 

 

Offline azett

  • Coder
  • Mitglied
  • ****
  • Beiträge: 2396
  • mozilo-Coder a.D.
    • Profil anzeigen
    • arvidzimmermann.de
Re: Wiki-Syntax [code] wird nicht interpretiert
« Antwort #3 am: 01. Oktober 2009, 07:49:34 »
Ursprünglich, ja :)
« Letzte Änderung: 01. Januar 1970, 01:00:00 von Guest »