forum.mozilo.de das Supportforummozilo Forum
Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?

Einloggen mit Benutzername, Passwort und Sitzungslänge

Autor Thema: Probleme mit mod_Rewrite  (Gelesen 770 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

 

Offline da_user

  • Mitglied
  • *
  • Beiträge: 32
    • Profil anzeigen
Probleme mit mod_Rewrite
« am: 02. Januar 2017, 12:09:02 »
Hi,

ich habe mir, um an meiner Seite gefahrlos experimentieren zu können, eine Virtuelle Maschine mit Linux und dem Lamp-Server aufgesetzt. Dann habe ich das BackUp meiner Homepage dadrauf in ein eigenes Verzeichnis kopiert. Dies habe ich übrigens schon öfter mit XAMPP auf meiner Windows-Kiste gemacht wo das bis jetzt immer Problemlos funktioniert hat.
Ich hatte dann erstmal Fehlermeldungen, weil GLib und mod_Rewrite nicht installiert sind. GLib habe ich nachinstalliert, funktioniert (zumindest laut Admin-Panel).
mod_Rewrite habe ich dann nach dieser Anleitung nachinstalliert: https://wiki.ubuntuusers.de/Apache/mod_rewrite/ Apache-Server neu gestartet und in PHP-Info habe ich auch ein "mod_rewrite" unter "Loaded Modules" stehen.
Das Admin-Panel bringt leider immer noch eine Fehlermeldung und bis auf die Startseite funktioniert keine Seite meiner HP. Ich habe daraufhin hier im Forum etwas gesucht, und bin auf den Tipp gestoßen, die .htaccess anzupassen, da soll eine Zeile

RewriteBase /"Mozilo-Verzeichnis"/

rein. Gemacht:
# mozilo generated not change from here to mozilo_end
Options -Indexes
RewriteEngine On
RewriteBase /mozilo/
RewriteRule ^(.*)/mod_rewrite_t_e_s_t\.html$ $1/index\.php?moderewrite=ok [L]
RewriteRule \.html$ index\.php [QSA,L]
# mozilo_end

Funktioniert leider immer noch nicht. Was gibts den noch, was ich tun kann/sollte?

VG
da_user
 

 

Offline Thorstn

  • Mitglied
  • *
  • Beiträge: 669
    • Profil anzeigen
    • Mensch, Musiker, Webdesigner - Thorsten aus Bochum
Re: Probleme mit mod_Rewrite
« Antwort #1 am: 02. Januar 2017, 12:39:14 »
Ich hatte mal ein ähnliches Problem: Offline (XAMPP) installiert, auf nen 1und1 Server hochgeladen und: kein mod-rewrite laut moziloCMS.

Ich habe dann einfach die Installation (install.php) auf dem Server nochmal komplett durchlaufen lassen, danach hatte ich auch mod_rewrite.

Vielleicht klappt das bei Dir ja auch.

Gruß,
Thorsten
www.mad-it.de - Wir lösen keine Probleme. Wir machen sie.
moziloCMS-Layouts auf mozilo-layouts.thorstn.com
webdesign-ruhr.de - Webdesign aus Bochum
 

 

Offline hausl78

  • Coder
  • Mitglied
  • ****
  • Beiträge: 1218
    • Profil anzeigen
Re: Probleme mit mod_Rewrite
« Antwort #2 am: 02. Januar 2017, 12:40:22 »
Zitat
RewriteBase /"Mozilo-Verzeichnis"/

Lass die Anführungzeichen mal weg.
 

 

Offline da_user

  • Mitglied
  • *
  • Beiträge: 32
    • Profil anzeigen
Re: Probleme mit mod_Rewrite
« Antwort #3 am: 02. Januar 2017, 16:33:35 »
Ich habe dann einfach die Installation (install.php) auf dem Server nochmal komplett durchlaufen lassen, danach hatte ich auch mod_rewrite.

Die muss ich dann dazu wieder draufspielen? Nur die Install.php oder mehr?

Zitat
RewriteBase /"Mozilo-Verzeichnis"/

Lass die Anführungzeichen mal weg.

Die Anführungszeichen sollen andeuten, dass das ganze ein Platzhalter ist. Erkennbar auch am zweiten Code-Block in dem ich meine .htaccess komplett kopiert habe ;-)
 

 

Offline Thorstn

  • Mitglied
  • *
  • Beiträge: 669
    • Profil anzeigen
    • Mensch, Musiker, Webdesigner - Thorsten aus Bochum
Re: Probleme mit mod_Rewrite
« Antwort #4 am: 02. Januar 2017, 20:34:31 »
Die muss ich dann dazu wieder draufspielen? Nur die Install.php oder mehr?

Nur die install.php (erneut) in das mozilo-Verzeichnis hochladen und den gesamten (!) Installationsprozess durchführen.

www.mad-it.de - Wir lösen keine Probleme. Wir machen sie.
moziloCMS-Layouts auf mozilo-layouts.thorstn.com
webdesign-ruhr.de - Webdesign aus Bochum
 

 

Offline hausl78

  • Coder
  • Mitglied
  • ****
  • Beiträge: 1218
    • Profil anzeigen
Re: Probleme mit mod_Rewrite
« Antwort #5 am: 03. Januar 2017, 08:18:33 »
Zitat
Das Admin-Panel bringt leider immer noch eine Fehlermeldung

Welche?
 

 

Offline da_user

  • Mitglied
  • *
  • Beiträge: 32
    • Profil anzeigen
Re: Probleme mit mod_Rewrite
« Antwort #6 am: 03. Januar 2017, 17:02:09 »
Nur die install.php (erneut) in das mozilo-Verzeichnis hochladen und den gesamten (!) Installationsprozess durchführen.

Werde ich probieren, danke.

Zitat
Das Admin-Panel bringt leider immer noch eine Fehlermeldung

Welche?

Genau kann ich sie jetzt hier nicht reinkopieren, da ich gerade unterwegs bin und nicht darauf zugreifen kann.
Beim Einloggen herhalte ich ein Fehlerfenster, dass mod_rewrite nicht verfügbar ist. mod_rewrite wird auch in dieser Auflistung, in der auch z.B. Glib aufgelistet wird, rot angezeigt (Adminpanel Startseite), zusammen mit dem entsprechenden Text und dem Verweis auf mehr Infos unter "LINK" (Wobei das kein Link ist, sondern nur Text, da scheint auch ein kleiner Bug drinnen zu sein).

VG
da_user
 

 

Offline da_user

  • Mitglied
  • *
  • Beiträge: 32
    • Profil anzeigen
Re: Probleme mit mod_Rewrite
« Antwort #7 am: 06. Januar 2017, 13:05:34 »
Hi,

ich bin jetzt endlich dazugekommen, das mal auszuprobieren. Also die instal.php rübergeschoben und aufgerufen.
Ich bekomme beim Menüpunkt "schönere URLs" folgende Fehlermeldung:

Zitat
"mod_rewrite" aktivieren
moziloCMS versucht jetzt auf dem Server das mod_rewrite-Modul zu aktivieren.
Dadurch werden besser lesbare und suchmaschinenfreundlichere URLs erzeugt.
Ist mod_rewrite verfügbar, kann es später im Admin-Bereich, im Tab "Einstellungen", nach Wunsch deaktiviert oder aktiviert werden.
mod_rewrite ist nicht verfügbar.
ACHTUNG Es gibt bereits eine .htaccess Datei. Wenn die nicht vom Provider ist, kann sie gelöscht werden.

Wenn ich die .htaccess lösche, verschwindet nur der "ACHTUNG..."-Text.

Ich zitiere jetzt nochmal einen Teil aus phpinfo():
Zitat
Configuration
apache2handler
Apache Version    Apache/2.4.18 (Ubuntu)
Apache API Version    20120211
Server Administrator    webmaster@localhost
Hostname:Port    127.0.1.1:80
User/Group    www-data(33)/33
Max Requests    Per Child: 0 - Keep Alive: on - Max Per Connection: 100
Timeouts    Connection: 300 - Keep-Alive: 5
Virtual Server    Yes
Server Root    /etc/apache2
Loaded Modules    core mod_so mod_watchdog http_core mod_log_config mod_logio mod_version mod_unixd mod_access_compat mod_actions mod_alias mod_auth_basic mod_authn_core mod_authn_file mod_authz_core mod_authz_host mod_authz_user mod_autoindex mod_deflate mod_dir mod_env mod_filter mod_mime prefork mod_negotiation mod_php7 mod_rewrite mod_setenvif mod_status

Wie gesagt, als Server handelt es sich um ein Linux Mint in einer Oracle V-Box mit LAMP.